欢迎访问CMS集中营! 本站QQ交流群:292800309
设为首页  |   加入收藏  |   RSS订阅  |   网站地图
CMS仿站建站技术教程_CMS免费模板源码下载-CMS集中营

首页 |  图文教程 |  免费模板 |  PHP |  MYSQL |  DIV+CSS |  JS |  ThinkPHP |  其他 | 

当前位置:首页 > 图文教程 > DISCUZ! > 正文
相关教程

Discuz!应用中心安装模板提示版本号不匹配的解决方法

时间:2015-12-30 13:31:28   作者:烈鹰网络工作室   点击:
有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候发布,而且之前的机制里一直是即使版本号不同,用户依然可以强制安装,但是,从X3.1后期开始,官方自己把自己的规矩改了,用户没有办法强制安装了,很多作者也没有在意这点,而且应用中心模板的审核与发布、更新的周期更让作者们苦等。
下面我们以discuz! X3的qing模板安装在X3.2上为例子讲解。
首先说的是错误提示图,如下图所示,官方发布的升级版版本号还是X2.5的,不过这不影响我们演示:

我们打开template/qing(其他模板为其他模板的目录)/discuz_style_qing.xml文件,在里面找到X2.5,
如果错误图提示为什么版本就搜什么版本,通常能搜索到至少两处
修改成自己的版本然后保存,重新在后台,界面,风格设置处安装模板即可。